is now replaced by the much more readable Groovy
if (name != null && param1 != null && param1.getUser() != null && name.equals(param1.getUser().getName()))
Amazing how a single character can improve readability that much and avoid potential NPEs. Also if you are curious about my use of == rather than the Java required .equals() see my post on More Groovy Sugar.
if (name && param1 && (name == param1.user?.name))
Most importantly I have inserted a hidden clue in this post and the first to solve the mystery will receive a free pop of their choice not to exceed 0.77 cents. The winner will be the first commenter with the correct answer.